Jump to content
Froxlor Forum

mangorausch

Members
  • Content Count

    14
  • Joined

  • Last visited

Community Reputation

0 Neutral

About mangorausch

  • Rank
    Froxie
  • Birthday July 17

Profile Information

  • Gender
    Not Telling
  • Location
    Vancouver
  1. So, funktioniert nun. Man muss das SSL Redirect erst deaktivieren, dann das Zertifikat erstellen mit php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug und anschließend wieder den SSL Redirect aktivieren. Vielleicht hilft es ja dem ein oder anderem.
  2. allow_url_fopen ist aktiviert. DNS funktioniert auch einwandfrei. So langsam weiß ich leider nicht weiter. Gibt's noch was, was ich checken könnte?
  3. Vielen Dank schon mal. - Ich glaube, ich habe den Fehler nun gefunden: # 35_froxlor_ssl_vhost_xxx.me.conf # Created 13.04.2016 08:48 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 202 (SSL) - CustomerID: x - CustomerLogin: xxx # no ssl-certificate was specified for this domain, therefore no explicit vhost is being generated # 35_froxlor_ssl_vhost_xxx.com.conf # Created 13.04.2016 08:48 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 224 (SSL) - CustomerID: x - CustomerLogin: xxx <VirtualHost x.x.xx.xx:443> ServerName xxx.com ServerAlias *.xxx.com ServerAdmin hello@xxx.com SSLEngine On SSLProtocol ALL -SSLv2 -SSLv3 SSLHonorCipherOrder On SSLCipherSuite EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH SSLVerifyDepth 10 SSLCertificateFile /etc/apache2/ssl/xxx.com.crt SSLCertificateKeyFile /etc/apache2/ssl/xxx.com.key DocumentRoot "/var/customers/webs/xxx/www_xxx_com/www_xxx_com/" FastCgiExternalServer /var/www/php-fpm/xxx/xxx.com/ssl-fpm.external -socket /var/lib/apache2/fastcgi/xxx-xxx.com-php-fpm.socket -idle-timeout 120 <Directory "/var/customers/webs/xxx/www_xxx_com/www_xxx_com/"> <FilesMatch "\.php$"> SetHandler php5-fastcgi Action php5-fastcgi /fastcgiphp Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> Alias /fastcgiphp /var/www/php-fpm/xxx/xxx.com/ssl-fpm.external Alias /awstats "/var/customers/webs/xxx/awstats/xxx.com" Alias /awstats-icon "/usr/share/awstats/icon/" ErrorLog "/var/customers/logs/xxx-error.log" CustomLog "/var/customers/logs/xxx-access.log" combined </VirtualHost> Es sieht so aus, als würde kein Zertifikat erstellt werden und die Datei wird nicht geupdated. Was kann man hier dagegen tun? Auf der .me Domain bleibt die Datei leer und bei der .com funktioniert es einwandfrei. Could not get Let's Encrypt certificate for xxx.me: Please check http://www.xxx.me/.well-known/acme-challenge/dHNHFo7QOiGsdGvbj9dOjbXLtrMr4DmBI8vbjBMCskc - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/www.xxx.me\/.well-known\/acme-challenge\/dHNHFo7QOiGsdGvbj9dOjbXLtrMr4DmBI8vbjBMCskc): failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":154}
  4. Leider bekomme ich immer eine Fehlermeldung im Cronjob, wenn ich ein Zertifikat mit Let's Encrypt erstellen möchte. In Chrome erhalte ich bei Aufruf der Domain: ERR_SSL_PROTOCOL_ERROR Meine Configuration in Froxlor sieht wie folgt aus:
  5. Hatte ich genutzt, leider nichts vernünftiges gefunden.
  6. Wie erstellt man dieses am besten?
  7. Moinsen. Besteht die M?glichkeit, dass "awstats" nicht im Kundenverzeichnis angezeigt werden kann? Idealerwei?e soll awstats weiter laufen und funktionieren in diesem Kundenverzeichnis, aber eben nicht angezeigt werden. Gibt es hierzu eine L?sung oder ist das "unm?glich"?
×
×
  • Create New...