Jump to content
Froxlor Forum

feiaweng

Members
  • Posts

    130
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by feiaweng

  1. Hallo aPollO, das ist noch auskommentiert in der /etc/php5/fpm/php-fpm.conf. Also alle 3 Werte nutzen somit den Default Wert 0. Welche Werte sollte ich hier einstellen? Gruss feiaweng
  2. die Werte habe ich von munin-graphen. Siehe Anhang. Die Namen darf ich leider nicht veröffentlichen. Aber man sieht den current verbrauch von RAM und CPU. Einige der Domains brauchen viel, andere eher weniger. Liegt an der Anzahl der Zugriffe. Bin gerade dabei die Artikel durchzulesen, aber geändert habe ich noch nichts. Das mache ich später mal in Ruhe. Was ich gelesen habe, ist das man mit pm = static/dynamic schon mal eine erste Option der Optimierung hat ? Gruss
  3. Ich habe jetzt umgestellt von FCGI auf PHP-FPM. Ich sehe allerdings dass trotzdem viel CPU und RAM benötigt wird. Bei einer Domain ganz besonders, aber da läuft auch ioncube. Dieses musste ich allerdings für PHP global aktivieren, da man es nicht wie Zendguard für einzelne Domains aktivieren kann. Kann ich noch was optimieren von den Schaltern die php-fpm anbietet? Welche Infos muss ich liefern? Danke feiaweng
  4. Danke d00p, ich aktviere das global. Aber interessehalber mal gefragt: Specify alternative path to FastCGI process manager config file. -> ist damit das php.ini file gemeint, welches nur die eine Zeile mit der zend_extension enthält? Ist aber nur aus Interesse gefragt. Ich bleibe lieber bei der Methode die nicht so kompliziert ist ? Gruss feiaweng
  5. Hallo Community, ich stelle gerade den phpHandler um von fcgid auf php-fpm. Generell funktioniert php-fpm. Folgendes Anliegen habe ich nun: Mit fcgid und eigener php.ini für jede Doamin konnte ich nur für eine Domain eine extension aktivieren zend_extension = /usr/lib/php/20151012/ioncube_loader_lin_5.6.so Mit php-fpm gibt es nun keine eigene php.ini für die Domain mehr. In der php-fpm Konfiguration für die Domain kann ich die obige Zeile nicht angeben. Dies führt zu einem error. Die zend_extension kann ich global einschalten in der etc/php5/fpm/php.ini Gibt es eine Möglichkeite diese zend_extension nur für eine Domain zu aktivieren? Danke Gruss feiaweng
  6. hab die conf files von /etc/php-fpm.d nach /etc/php5/fpm/pool.d kopiert. Läuft jetzt. Danke erstmal. Gruss feiaweng
  7. unter /etc/php-fpm.d finde ich die .conf files. Wahrscheinlich sind die files angelegt worden vor der Umstellung auf /etc/php5/fpm/pool.d Soll ich die configfiles einfach dort hinkopieren? Meinst du mit den fpm Daemon Einstellungen das file /etc/php5/fpm/php-fpm.conf include=/etc/php5/fpm/pool.d/*.conf Gruss
  8. ich habe dummerweise irgendwas in der apache config überschrieben, ich vermute mal mods-available/fastcgi.conf Bekomme nun beim Starten des php-fpm folgenden Error: Starting The PHP FastCGI Process Manager... php5-fpm[14608]: [07-Feb-2019 10:44:45] WARNING: Nothing matches the include pattern '/etc/php5/fpm/pool.d/*.conf' f...ine 129. php5-fpm[14608]: [07-Feb-2019 10:44:45] ERROR: No pool defined. at least one pool section must be specified in config file php5-fpm[14608]: [07-Feb-2019 10:44:45] ERROR: failed to post process the configuration php5-fpm[14608]: [07-Feb-2019 10:44:45] ERROR: FPM initialization failed systemd[1]: php5-fpm.service: main process exited, code=exited, status=78/n/a systemd[1]: Failed to start The PHP FastCGI Process Manager. systemd[1]: Unit php5-fpm.service entered failed state. Ich komm grad leider gar nicht weiter, und bräuchte Hilfe. Gruss feiaweng
  9. Danke für den Tipp. Hab's wieder hinbekommen. Musste wieder zurückstellen auf fcgid, da ich den Fehler nicht beseitigen konnte. Irgendwas ist auf dem System anders als auf der Testmaschine. Ich guck nachher mal in die Logs. Gruß feiaweng
  10. hat mit ein paar kleinen Problemen funktioniert auf dem Backup-System. Auf dem Live-System leider nicht. Weiss leider nicht warum. Dummerweise habe ich mir jetzt selbst ein Ei gelegt. Ich habe versehentlich in Froxlor unter Einstellungen fcgid und php-fpm deaktiviert. Nun komme ich an Froxlor nicht mehr ran um es zu aktivieren. Die URL ist nun auf dem froxlor Host nicht mehr erreichbar, da php ja nicht läuft. Wie kann ich das wieder aktiveren, direkt im mysql? Die froxlor DB zurückspielen aus einem dump hat nicht funktioniert. Für Ideen wäre ich super dankbar. LG feiaweng
  11. Danke dir. Ich mach das mal, und melde mich dann. Gruss
  12. ich weiss nicht mehr, wo ich das gelesen hatte. Habe aber gerade gesehen, dass bei Apache 2.4 FPM besser wäre. Gibt es hier ein kleines Howto, was zu beachten ist? Einfach in froxlor umstellen wäre ja bestimmt zu einfach :-) LG feiaweng
  13. ich dachte, man soll fcgid nehmen, weil der bessere Performance hat. Kann ich auf einem Livesystem einfach auf FPM umstellen ohne das was passiert? Liegen ja Kundenwebseiten drauf.
  14. Hallo, ich habe froxlor auf einem debian 8 system mit apache 2.4 und php5.6 laufen. Es laufen ca. 15 verschiedene Websites. Alle mit fcgi. Es handelt sich um einen KVM Server mit 4 vCPU und 16 GB RAM. PHP fcgi benötigt viel RAM. Ich vermute ein Upgrade auf PHP 7.2 würde helfen, da es die php Performance verbessern soll. Allerdings kann ich jetzt grad auf Grund von Webseitenproblemen mit PHP 7 nicht upgraden. Kann ich noch irgendwo an der Performance Schraube drehen, damit der Server nicht ständig eine Load von mindestens 1 hat? In den Logs sind keine Fehler vorhanden, im Apache log auch nicht. Danke schonmal. Gruss feiaweng
×
×
  • Create New...