Jump to content
Froxlor Forum

Bubble

Members
  • Posts

    183
  • Joined

  • Last visited

  • Days Won

    3

Everything posted by Bubble

  1. Hallo, ich vermute mal, das du die E-Mail-Adresse des Besuchers benutzt hängt damit zusammen, das du direkt auf die E-Mail antworten willst, ohne die Mail-Adresse erst aus dem Content der Mail rauszukopieren. Dies erreicht du aber auch, wenn du die Adresse des Besuchers auch als "reply-to"-Adresse angeben. Die "from"-Adresse muss aber, wie D00p ja schon gesagt hat mit der übereinstimmen, mit der du dich am SMTP-Server authentifizierst. Das du die Fehlermeldung erst seit 3 Wochen bekommst könnte in Updates deines Servers liegen. Ich gehe mal davon aus, das du regelmäßig updates deiner Softwarepakete vornimmst. Im Rahmen dieser Updates wird sicher auch mal der SMTP-Server aktualisiert worden sein und dieser verbietet es inzwischen das es einen unterschied zwischen Absender und authorisiertem Benutzer gibt. Am besten also einfach das Script ein kleinwenig anpassen und schon steht dem weiteren Mail-Versand nichts mehr im Wege. Gruss cardman
  2. Bubble

    RspamD

    Hallo euch allen, ich hätte da mal eine Frage zur Spam-Abwehr. Seit einiger Zeit verfolge ich Berichte zum Thema RspamD als Ersatz für Spamassassin. In so ziemlich allen Berichten darüber wird RspamD gelobt und der Einsatz empfohlen. Jetzt zu meiner Frage: hat einer von euch schon Erfahrung damit im Live-Einsatz und vorallem auch im zusammenspiel mit Froxlor. Ich denke zwar nicht, das es beim zusammenspiel mit Froxlor ein Probleme geben sollte, aber besser einmal zuviel als zuwenig gefragt. Danke schonmal für eure Kommentare dazu. Gruss cardman
  3. Hallo, die Meldung hat grundsätzlich erstmal wenig mit Froxlor oder der Einbindung von PHP zu tun. Die Fehlermeldung besagt lediglich, das on der Datei /lib/init.php in der Zeile 216 eine Ausgabe erfolgt. In meiner init.php steht in Zeile 215 "session_start()" und vor diesem Befehl darf einfach keine Ausgabe erfolgen. Also musst du deine Datei in den Zeilen davor kontrollieren ob dort bereits eine Ausgabe erfolgt. Es reicht auch schon, wenn vor dem ersten "<?php" eine Leerzeile steht. Einfach mal schauen, vielleicht hilft das ja schon. Gruss Cardman
  4. Hallo, ich würde auch gerne noch meine Senf dazu geben Zum einen die Frage, wenn die Software in deinen Augen, soviele Defizite aufweist, warum benutzt du sie dann? Niemand zwingt dich Froxlor zu benutzen. Ich kenne einige Serveranbieter die bieten dir zu ihren Servern auch eine Plesk-Lizenz an. Da hast du dann ein "Rundum-Sorglos-Paket" und keine Probleme mehr. Ich von meiner Seite aus kann nur sagen, das Froxlor eine gute Software ist. Auf meinen Servern läuft die Software schon seit 10Jahren (anfangs noch unter SysCP). In meinen augen hält es eine gute die Waage zwischen Funktionialität und dem was ich als Server-Admin noch alles selber machen kann. Man wird nur in einem kleinen Rahmen zu irgendwelchen Software-Paketen gezwungen. Den Rest kann man mehr oder weniger selbst entscheiden was man installiert. Ausserdem kann man es relativ einfach selbst erweitern und an seine Bedürfnisse anpassen. Man muss sich da halt den Aufwand machen und selbst Programmieren, dafür hat man dann aber am ende eine Lösung die auf einen selbst massgeschneidert ist. Zu den "fehlenden" Funktionen: 99% meiner Kunden sind froh und zufrieden, das sie nicht so viel einstellen können, sondern das einfach alles so funktioniert, wie es funktioniert. Die wollen sich nicht mit dem Fach-Chinesisch eines Spamfilters auseinander setzen, die wollen einfach nur keinen Spam bekommen. In einer älteren Version von Froxlor gab es auch mal einen 1-Click-Installer. Dieser wurde insgesamt vielleicht 2mal benutzt, von daher ist das eine Funktion die ich nicht benötige. Für Backups gibt es, wie Shortie schon geschrieben hat, viele gute Programme, die das alle mehr oder weniger gut können. Also warum Manpower in etwas investieren was es schon gibt. Und zum guten Schluss, für die 1% Kunden, die weitere Funktionen Wünschen, biete ich an, diese über den Support anzufragen und dann von einem Admin ausführen zu lassen (sofern möglich). Gerade bei CronJobs weiß ich gerne was auf meinen Servern läuft und bin ganz froh, das nicht einfach jeder alles per CJ ausführen lassen kann. Zum Abschluss noch ein Dank an D00p und alle mitwirkenden für die Entwicklung und Pflege von Froxlor. Gruss Cardman
  5. Ich hab leider mit CentOS 7 keine Erfahrung, ich nutze für meine Server Debian als System. Vielleicht kann ja jemand anderes helfen.
  6. Hallo, schau mal hier nach: https://github.com/Froxlor/Froxlor/wiki/apache2-with-fcgid unter dem Punkt "Setting up suexec" damit wird der Apache unter dem User des Eigentümers ausgeführt. Zu dem Fehler schau mal hier nach: https://forum.froxlor.org/index.php?/topic/12710-invalid-command-fastcgiexternalserver/ grundsätzlich könnte das helfen. Gruss cardman
  7. Hallo, vielleicht solltest du die UID für diesen Ordner ändern. Die richtige UID bekommst du aus der Datenbank. Das Problem könnte daran liegen, das die Zuordnung zwischen der UID und dem Benutzer "test" nicht korrekt ist. Die Fehlermeldung beim Cron-Job kommt von Apache. Wenn du dir den VHost für die dem User "test" zugeordneten Domain(s) anschaust, müsstest du dadrin etwas wie: SuexecUserGroup "test" "test" stehen. Wenn es den Benutzer "test" aber nicht gibt führt es zu diesem Problem bzw zu dieser Fehlermeldung. Froxlor legt keine Benutzer an. Die Benutzernamen die angezeigt werden, stammen nur aus der Datenbank und sind nur virtuelle User.
  8. Komisch. Dann musst du mal nachschauen, wo der User "test" her kommt. Irgendwo muss der ja stehen, ohne das er existiert. Vielleicht mal auf dem Server im "webs" Ordner schauen, ob es da einen Ordner gibt, der entweder als Eigentümer "test" hat oder nur eine UID da stehen hat. Wenn es einen Ordner gibt, mit dem Benutzer Test, kannst du den anpassen. Sollte es einen Ordner geben, der nur eine UID da stehen hat, dann könnte der das Problem auslösen, in dem die UID einem ungültigem Benutzer zugeordnet ist.
  9. Hasst du den in den beiden Tabellen in der Froxlor-Datenbank nachgeschaut, ob dort was mit test angelegt ist? Das Problem hatte ich nämlich mal gehabt. Ich hatte bei einem User nachträglich, über die Datenbank, den Benutzername angepasst. Damit begannen die Probleme. Erst nachdem ich die beiden "ftp_*" Tabellen auch angepasst hatte, war das Problem beseitigt.
  10. Hallo, die User werden auch mit Libnss-mysql nicht wirklich angelegt. Die Benutzer werden damit nur aus der Datenbank ausgelesen. Zur Not, wenn du in Froxlor selbst keinen Benutzer "test" angelegt hast, dann leg ihn einfach im System an, ohne Berechtigung und dann sollte das Problem normalerweise behoben sein. Grundsätzlich sollte es aber keine Benutzer geben, die es nicht gibt, ausser du hättest z.B. nachträglich über die Datenbank einen Benutzernamen geändert. Dann kann es sein, das in den Tabellen "ftp_users" und "ftp_groups" noch fehlerhafte Einträge sind, die zu diesem Problem führen. Gruss cardman
  11. Hallo, damit das mit dem Owner klappt darfst du PHP nicht als Apache Modul installieren. Stattdessen muss es als FCGID oder PHP-FPM eingebunden werden. Entsprechende Anleitungen findest du auf der Github seite von Froxlor im Bereich WIKI. Für beide Lösungen findest du wieder im Adminbereich unter "Konfiguration" nach der Auswahl deiner Distro und des Services "Sonstige (System)" im Bereich Daemon die Installations- und Konfigurationsanleitungen. Damit sollte auch das Problem gelöst werden. Gruss Cardman
  12. Hallo, ohne mich bisher näher mit Quota und deren Einrichtung auseinander gesetzt zuhaben, klingt das für mich danach als müsstest du noch "libnss-mysql" einrichten. Schau mal im Adminbereich unter "Konfiguration" nach: dort deine Distro auswählen und den Service "Sonstige (System)" auswählen. Unter Daemon findest du dann "libnss-mysql". Ich kann dir aber nicht sagen, ob das wirklich dein Problem löst, es klingt für mich aber danach. Sollte ich damit komplett falsch liegen, bitte die Antwort ignorieren / korregieren. Gruss cardman
  13. Hallo, hier mal eine Standardantwort: Ein paar mehr an Infos, wie z.B. Config-Dateien oder Log-Dateien, wäre wichtig um dir helfen zu können. Auch wenn das jetzt doof klingt, aber wir haben hier alle keine Glaskugel um aus den paar Zeilen da oben die Antwort zu finden. Gruss cardman
  14. Hallo xavx, ich würde mal ausprobieren, ob es mit www klappt, wenn du bei ServerAlias den Eintrag "www (www.domain.tld) auswählst. Dort hast du momentan nämlich "no Alias" ausgewählt, also wird auch keiner angelegt. Gruss Cardman
×
×
  • Create New...