Jump to content
Froxlor Forum

BooosesThaSnipper

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About BooosesThaSnipper

  • Rank
    Newbie
  1. BooosesThaSnipper

    Fehler beim anlegen neuer Datenbanken

    Ist zwar ein paar Tage her, aber hier ein kleines Feedback: Habe sämtliche Rechte in der Datenbank für root nochmals gelöscht und frisch angelegt. Die werte sind exakt die gleichen (output mittels diff überprüft) aber nun geht es. Es scheint als hätte sich da irgendwas beim anlegen verschluckt.
  2. BooosesThaSnipper

    Fehler beim anlegen neuer Datenbanken

    HI, root Zugriff und Shell hatte ich schon für die Installation anpassen müssen, da sich froxlor sonst nicht hätte installieren lassen. Ist ja die Geschichte mit Plugin Type und den Rechten. Hab gerade nochmal folgendes Gemacht: GRANT ALL ON *.* TO 'root'@'127.0.0.1'; GRANT ALL ON *.* TO 'root'@'localhost'; FLUSH PRIVILEGES; MariaDB [mysql]> select Host,User,plugin,password_expired from user where User = 'root'; +-----------+------+--------+------------------+ | Host | User | plugin | password_expired | +-----------+------+--------+------------------+ | localhost | root | | N | | 127.0.0.1 | root | | N | +-----------+------+--------+------------------+ 2 rows in set (0.00 sec) Keine Besserung... bin irgendwie ratlos...
  3. BooosesThaSnipper

    Fehler beim anlegen neuer Datenbanken

    So einfach ist das Problem nicht! Er kommt ja sogar soweit, die Datenbank anzulegen und diese Rechte hat nur der Root User, als kommt er rein, er macht nur nicht weiter.... Hab auch gerade nochmals die Credentials versucht die in der "userdata.inc.php" hinterlegt sind und diese funktionieren ohne Probleme. CREATE DATABASE `xxxxxxsql1`; GRANT ALL PRIVILEGES ON `xxxxxxsql1`.* TO 'xxxxxxsql1'@'127.0.0.1' IDENTIFIED BY 'password'; SET PASSWORD FOR 'xxxxxxsql1'@'127.0.0.1' = PASSWORD('xxxxxxxxxxxxxxxxxx'); GRANT ALL PRIVILEGES ON `xxxxxxsql1`.* TO 'xxxxxxsql1'@'localhost' IDENTIFIED BY 'password'; SET PASSWORD FOR 'xxxxxxsql1'@'localhost' = PASSWORD('xxxxxxxxxxxxxxxxxx'); FLUSH PRIVILEGES INSERT INTO `panel_databases` (`customerid`, `databasename`, `description`, `dbserver`) VALUES ('10', 'xxxxxxsql1', 'Beschreibung', '0'); UPDATE `panel_customers` SET `mysqls_used` = `mysqls_used` + 1, `mysql_lastaccountnumber` = `mysql_lastaccountnumber` + 1 WHERE `customerid` = '10'; Manuell funktioniert es ohne Probleme...
  4. BooosesThaSnipper

    Fehler beim anlegen neuer Datenbanken

    Hi, die Idee hatte ich auch schon, hab dann aber auch die vorgeschlagenen Passwörter getestet mit nur Großbuchsten, Kleinbuchstaben und Zahlen... Ohne Sonderzeichen.
  5. BooosesThaSnipper

    Fehler beim anlegen neuer Datenbanken

    Hi Cardman, halte ich für relativ unwahrscheinlich, da bereits Datenbanken anderer Kunden angelegt wurden, die einen längeren Kundennamen hatten und somit inkl Suffix deutlich länger sind. Aber danke für den Denkanstoß. Grüße Markus
  6. BooosesThaSnipper

    Fehler beim anlegen neuer Datenbanken

    Hi Zusammen, ich hab gerade Froxlor auf einem neuen Server gerade frisch installiert und soweit alles eingerichtet. Läuft auch bisher alles. OS: Debian 9 Wollte jetzt einige Datenbanken für verschiedene Kunden anlegen was auch zu Beginn ohne Probleme funktioniert hat. Nun kommt auf einmal eine Fehlermeldung, dass es nichtmehr möglich wäre eine neue Datenbank anzulegen: A database error occurred SQLSTATE[42000]: Syntax error or access violation: 1044 Access denied for user 'root'@'127.0.0.1' to database 'xxxxxxxsql1' Versuche ich es erneut erscheint folgende Meldung: A database error occurred SQLSTATE[HY000]: General error: 1007 Can't create database 'xxxxxxxsql1'; database exists Habe mir die entsprechenden MariaDB Logs angeschaut und das sieht meiner Meinung nach auch soweit OK aus, aber als es noch funktioniert hat, sah es anders aus: Ohne Funktion: 360 Query CREATE DATABASE `xxxxxxxsql1` 360 Query INSERT INTO `panel_syslog` SET `type` = '6', `date` = '1523526125', `action` = '10', `user` = 'xxxxxxx', `text` = 'created database \'xxxxxxxsql1\'' 360 Query GRANT ALL PRIVILEGES ON `xxxxxxxsql1`.* TO 'xxxxxxxsql1'@'127.0.0.1' IDENTIFIED BY 'password' Zu beginn als es noch funktioniert hat: 9818 Query CREATE DATABASE `xxxxxxxsql1` 9818 Query INSERT INTO `panel_syslog` SET `type` = '6', `date` = '1523522601', `action` = '10', `user` = 'xxxxxxx', `text` = 'created database \'xxxxxxxsql1\'' 9818 Query GRANT ALL PRIVILEGES ON `xxxxxxxsql1`.* TO 'xxxxxxxsql1'@'127.0.0.1' IDENTIFIED BY 'password' 9818 Query SET PASSWORD FOR 'xxxxxxxsql1'@'127.0.0.1' = PASSWORD('xxxxxxx') 9818 Query GRANT ALL PRIVILEGES ON `xxxxxxxsql1`.* TO 'xxxxxxxsql1'@'localhost' IDENTIFIED BY 'password' 9818 Query SET PASSWORD FOR 'xxxxxxxsql1'@'localhost' = PASSWORD('xxxxxxx') 9818 Query FLUSH PRIVILEGES 9819 Query INSERT INTO `panel_databases` (`customerid`, `databasename`, `description`, `dbserver`) VALUES ('2', 'xxxxxxxsql1', 'Beschreibung', '0') 9819 Query UPDATE `panel_customers` SET `mysqls_used` = `mysqls_used` + 1, `mysql_lastaccountnumber` = `mysql_lastaccountnumber` + 1 WHERE `customerid` = '2' Ein Blick in die Datenbank zeigt, dass der User nicht wirklich angelegt wird: MariaDB [mysql]> select Host,User,Password,authentication_string,password_expired from user where user.User = 'xxxxxxxsql1'; Empty set (0.00 sec) Die Datenbank existiert aber, so dass ich sie für einen neuen Versuch erstmal löschen muss mittels "DROP DATABASE xxxxxxxsql1;" Irgendwie scheint es, dass das SQL Statement nicht ganz abgearbeitet wird. Hat jemand einen Tipp für mich, wie ich hier weiterkomme? Sollten noch wichtige Infos Fehlen, geht einfach kurz Bescheid, dann liefere ich die benötigten Daten gerne weiter. Grüße Markus
×