Jump to content
Froxlor Forum

localhorst

Members
  • Content Count

    11
  • Joined

  • Last visited

  • Days Won

    1

Posts posted by localhorst

  1. Wieder ein Stück weiter, hab es zwar gelesen aber erst hat's geklickt.

    In "/usr/lib/systemd/system/php-fpm7.service" musste ich "ProtectSystem=full" auskommentieren, dann startete der php-fpm7.service schonmal.

    Die erste Webseite funktioniert nun schonmal mit PHP7. Wenn ich nun in den Domains die nächste Webseite auf die PHP7-Konfiguration setze und danach den Cronjob ausführe legt er zwar die Config-File an aber wechselt nicht zu php-fpm7.service, also der socket bleibt vorn mit "1-..." und wird nicht zu "2-...". Ich probiere mal weiter.

  2. Okay das hat mir schonmal geholfen, ich nutze aber ArchLinux und dort ist der Pfadaufbau etwas anders:

    PHP8 = /etc/php/php-fpm.d + /etc/php/conf.d

    PHP7 = /etc/php7/php-fpm.d + /etc/php7/conf.d

    Schaue ich mir nun eine Konfigurationsdatei in conf.d zu einer Webseite für welche PHP7 zugewiesen wurde an steht darin:

    listen = /etc/php/conf.d/2-xxxxx-php-fpm.socket

    Ich denke, dass dort genau mein Fehler liegt denn php-fpm7 gibt den Fehler aus:

    [ERROR] unable to bind listening socket for address '/etc/php/conf.d/2-xxxxxx.de-php-fpm.socket': Read-only file system (30)

    Hier müsste bei listen wohl eher /etc/php7/conf.d/... stehen.
     

  3. Hallo an alle,

    habe nun PHP 8 mal installiert und wollte PHP 7.4 in verschiedenen Projekten vorerst weiternutzen.

    Vorgangsweise in Froxlor:

    • PHP-FPM Versionen -> Neue PHP Version erstellen -> PHP7 - PHP7 - systemctl restart php-fpm7 - /etc/php/7/fpm/pool.d/dynamic
    • PHP-Konfigurationen -> Neue PHP Konfiguration erstellen ->   PHP 7 Konfiguration erstellt
    • Domains -> und in der entsprechenden Domain die PHP7 Konfiguration zugewiesen
    • Der Benutzer hat auch die entsprechenden Rechte zur Ausführung der beiden Konfigurationen bekommen im Bereich Kunden.
    • Danach Cronjob ausgeführt.

    Im Ergebnis erhalte ich im Ordner /etc/php/conf.d das entsprechende Socket mit der 2-<<benutzername>>-<<domain>>.socket

    • php-fpm und php-fpm7 sind gestartet

    Das Problem ist nun, dass die entsprechende Seite welche auf PHP7 laufen soll, weiter unter der Standardkonfiguration (PHP 8 ) läuft, das zeigt auch der Status von php-fpm über systemctl. 

    Vielleicht hat der eine oder andere eine Idee, würde mich freuen. :)

     

    EDIT: Okay das erste Problem was ich erkenne ist, dass die socket-Dateien nicht in /etc/php/conf.d sondern in /etc/php7/conf.d liegen sollten.

  4. Danke für den Hinweis, habs erledigt. Nur die froxlor-conf ist dort nicht mit drin. ☺️ Kann ich die irgendwie ausfindig machen? Hab die nginx-conf von froxlor (10er) auf den Standard-Socket umgebogen mit 777-Rechten, nur damit ich erstmal wieder auf das Panel kam.

  5. Wenn Du den Pfad "/etc/php/php-fpm.d" meinst, da ist tatsächlich nur die www.conf drin. Du bist spitze, die conf-Dateien liegen in "/etc/php/conf.d" und ich habe nun mal mittels

    ln -s /etc/php/conf.d/XXX.de.conf /etc/php/php-fpm.d/XXX.de.conf

    verlinkt, php-fpm neu gestartet und siehe da die eine Seite lässt sich wieder aufrufen. Das mache ich nun noch mit allen anderen Seiten.

    Vielen, vielen Dank!!! ☺️

  6. Danke für die Antwort, habe php-fpm neu gestartet und er zeigt keine Fehler an. Der Dienst läuft also.

    Zitat

    php-fpm.service - The PHP FastCGI Process Manager
        Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; enabled; vendor preset: disabled)
       Drop-In: /etc/systemd/system/php-fpm.service.d
                └─override.conf
        Active: active (running) since Thu 2021-02-04 19:21:29 CET; 4s ago
      Main PID: 47865 (php-fpm)
        Status: "Ready to handle connections"
         Tasks: 3 (limit: 9514)
        Memory: 6.5M
        CGroup: /system.slice/php-fpm.service
                ├─47865 php-fpm: master process (/etc/php/php-fpm.conf)
                ├─47867 php-fpm: pool www
                └─47868 php-fpm: pool www

    Feb 04 19:21:29 v22018086702971204 systemd[1]: Starting The PHP FastCGI Process Manager...
    Feb 04 19:21:29 v22018086702971204 php-fpm[47865]: [NOTICE] fpm is running, pid 47865
    Feb 04 19:21:29 v22018086702971204 php-fpm[47865]: [NOTICE] ready to handle connections
    Feb 04 19:21:29 v22018086702971204 systemd[1]: Started The PHP FastCGI Process Manager.
    Feb 04 19:21:29 v22018086702971204 php-fpm[47865]: [NOTICE] systemd monitor interval set to 10000ms

     

     

  7. Guten Abend,

    irgendwie habe ich es geschafft sämtliche angelegte Sockets (/run/php-fpm/*) zu löschen. Wahrscheinlich durch das update auf PHP8 welches ich dann wieder zurückgesetzt hab auf PHP7.

    Gibt es eine Möglichkeit diese socket-Dateien wiederherstellen zu lassen? Habe schon den Cronjob manuell mit --force durchgeführt aber das klappt leider nicht.

    Vielen Dank für die Hilfe.

  8. vor 22 Stunden schrieb d00p:

    Der User froxlorlocal hat damit schon Mal nichts zu tun, der ist für Froxlor selbst, das ist keine Gruppe die sich die Kunden teilen.

    Was du für user1 installierst ist natürlich auch nur für diesen nutzbar. Geteilte Files sind in diesem Setup ein Berechtigungs-Chaos. Würde ich so nicht machen. Ich weiss nicht welches Tool du da verwendest, aber Matomo z.B. bindet halt einfach ein Script EXTERN ein (via URL) - so kann man eine Installation für viele Seiten verwenden.

    Hallo und vielen Dank für den Denkanstoß, hab tatsächlich JS-Code zum Einbinden gefunden, dieser funktioniert von externen Seiten. Mit PHP (require) klappt das leider nicht aber nicht so schlimm. Matomo / Piwik habe ich vor ein paar Jahren mal genutzt, jetzt habe ich OWA, sprich Open Web Analyse.

    Das OWA überträgt ja auch Zugangspasswörter per EMail, aber leider werden keine zugestellt und in /var/log/ gibt es leider keine mail.log obwohl in Froxolor unter Einstellungen/Mailserver-Einstellungen 2x /var/log/mail.log standardmäßig drin steht. 🤨 Anonsten läuft Froxlor super unter ArchLinux, hätte ich anfangs nicht gedacht.

  9. Hallo ich nutze Froxlor auf einem Arch Linux System und das funktioniert auch super, nach ein paar Anpassungen.

    Nun wollte ich Open Web Analyse (OWA) installieren, das habe ich soweit auch geschafft, was ich aber nicht hinbekomme ist die Erreichbar von mehreren verschiedenen Benutzern. Also z. B. liegt das OWA-Tool im Bereich von User1 (Benutzer und Gruppe) auf dem Server. Dann gibt es zwei verschiedene Kunden z. B. User1:User1 und User2:User2. Stelle ich nun auf User1:froxlorlocal und User2:froxlorlocal um erreicht User2 trotzdem die Webanalyse nicht. Da ich eine php-Datei mittels require einbinden muss kommt dann folglich der Fehler:

    Zitat

    failed to open stream: Permission denied in /var/www/customers/webs/user2/webseite.de/index.php on line 9

    Gibt es eine Möglichkeit so ein Tool quasi global erreichbar zu machen, meinetwegen auch in /usr/share/webapps/owa?

    Vielen Dank im Voraus.

    Grüße, Tommy

×
×
  • Create New...