Jump to content
Froxlor Forum

mike87

Members
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About mike87

  • Rank
    Newbie

Profile Information

  • Gender
    Male
  • Location
    Kaiserslautern
  • Interests
    Old cars / photography / big networks
  1. Before I imported the old database I did a fresh install and my froxlor_root user was accepted. It took me some time but I found the issue. MariaDB got a bug in 10.3. Granting ALL PRIVILEGES lacks DELETE HISTORY. So another grant ALL PRIVILEGES fails. You need to grant all priviliges manually and it is working. (See Bug Report)
  2. I know. I just wanted you to know about this problem. Debian 10/MariaDB 10.3 uses unix_socket as plugin for the root user. So this isn't working anymore and you have to create another root-like user. That's why I use froxlor_root with full global rights, identified by password from 127.0.0.1/localhost/server-ip. Connecting via shell is working: mysql -u froxlor_root -p May you know the SQL-statement so I could test it via shell?
  3. That doesn't change anything. SQLSTATE[42000]: Syntax error or access violation: 1044 Access denied for user 'root'@'127.0.0.1' to database 'web8sql1' But I think that isn't intended to work. Newer releases only accept root from shell if you are currently a root user.
  4. I enabled mod_php, looked into it ten times and still missed that it was disabled again... Thx a lot. Another strange thing I found is that I disabled a customer and tried to reenable it. Ending here: A database error occurred SQLSTATE[42000]: Syntax error or access violation: 1044 Access denied for user 'froxlor_root'@'127.0.0.1' to database 'web8sql1' Dear froxlor-team, the following error has been reported by a user: ------------------------------------------------------------- 42000 SQLSTATE[42000]: Syntax error or access violation: 1044 Access denied for user 'froxlor_root'@'127.0.0.1' to database 'web8sql1' File: lib/Froxlor/Database/Database.php:203 Trace: #0 [internal function]: PDO->query('GRANT ALL PRIVI...') #1 lib/Froxlor/Database/Database.php(203): call_user_func_array(Array, Array) #2 lib/Froxlor/Database/Manager/DbManagerMySQL.php(203): Froxlor\Database\Database::__callStatic('query', Array) #3 lib/Froxlor/Api/Commands/Customers.php(1081): Froxlor\Database\Manager\DbManagerMySQL->enableUser('web8sql1', '127.0.0.1') #4 admin_customers.php(376): Froxlor\Api\Commands\Customers->update() #5 {main} ------------------------------------------------------------- Froxlor-version: 0.10.0-rc2 DB-version: 201904250 End of report User froxlor_root got full global rights. So this shouldn't be a problem. Any guesses?
  5. As recommended I copied my database to a fresh Debian 10 and started the internal update. Changed the IP and got stuck. Apache doesn't start due: AH00526: Syntax error on line 11 of /etc/apache2/sites-enabled/28_froxlor_normal_vhost_web1.s01.XXXX.info.conf: Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration These are the lines for open basedir and email. Any recommendations how to fix this? If I remove all php_admin_value Entries from all fines it is running fine.
×
×
  • Create New...