Jump to content
Froxlor Forum

Leaderboard

Popular Content

Showing content with the highest reputation since 01/31/10 in Posts

  1. Sorry wenn ich mich da einklinke. Aber dein Standpunkt kann ich hier nicht verstehen. Selbst wenn D00p für das Problem nur 5 Minuten brauchen sollte. Dann frag dich doch mal wie lange du dafür brauchen würdest und wie viel dir diese Zeit wert ist. D00p und auch einige andere hier im Forum haben sich das Wissen, das ein Problem in 5 Minuten beseitigt ist, ja auch aneignen müssen. Das ist ihnen nicht einfach so zugeflogen. Das bezahlst du ja auch mit den 120€. Ich erlebe das in meinem Alltag auch oft, das mir gesagt wird, das ich für dies oder jenes ja nur 5 Min brauche, warum ich dafür dann soviel berechnen würde. In meinen Augen zeigst du mit dieser Aussage wie gering deine Wertschätzung anderen gegenüber ist. Gruss cardman
    1 point
  2. First thoughts: Use if file_exist in the template directory logo_custom.png and logo_custom_login.png. If nothing found use database. If nothing found in database use logo.png. So you have only include a few lines 😉
    1 point
  3. Ich bin kein Freund von Fragen zu stellen und dann zu sagen, "Danke hat sich erledigt, habe es selber geschafft" ohne dann für andere eine Lösung zu präsentieren. Falls jemand auch mal bitwarden_rs über Froxlor mit einem Apachen 2.4 und SSL erstellen möchte, hier die nötigen VHost Einträge die entweder direkt, oder als zusätzliche Einträge zu den Standart VHost Einträgen zugefügt werden müssen. Hier für den Port 80 > 9000 ProxyPreserveHost On ProxyRequests Off <Proxy *> AllowOverride All Order allow,deny Allow from all </Proxy> ProxyPass / http://localhost:9000/ ProxyPassReverse / http://localhost:9000/ Und hier für den SLL Port RewriteEngine On RewriteCond %{HTTP:Upgrade} =websocket [NC] RewriteRule /notifications/hub(.*) ws://127.0.0.1:3012/$1 [P,L] ProxyPass / http://127.0.0.1:9000/ ProxyPreserveHost On ProxyRequests Off RequestHeader set X-Real-IP %{REMOTE_ADDR}s Natürlich kann auch jeder andere frei Port benutzt werden.
    1 point
  4. Danke für die schnelle Antwort - diese Option kannte ich noch nicht und das war es natürlich Ich wünsche einen schönen Abend und bleib gesund!
    1 point
  5. Du musst in den Optionen folgendes aktivieren: Welcher Webserver wird benutzt? habe dieses Shop System oh. Probleme mit LE SSL getestet und ging ohne Probleme. Und wie d00p, schon angemerkt hat, wurde deine Shop Seite per IP anstatt mit einer Domain installiert. Daher kannst du probieren in der DB, Manuel die Einträge zu ändern oder installiert den Shop noch mal richtig mit einer Domain. *Nachtrag* Du kannst die die Domain auch per DB ändern. In folgenden Tabellen findet du die Einträge: - ps_configuration - ps_connections_source Test Installation inkl. Demo Content > https://testing.anime-mitsuketa.tokyo/
    1 point
  6. root@con1:~# a2dismod php7.0 && a2enmod php7.4 Module php7.0 disabled. To activate the new configuration, you need to run: systemctl restart apache2 Considering dependency mpm_prefork for php7.4: Considering conflict mpm_event for mpm_prefork: Considering conflict mpm_worker for mpm_prefork: Module mpm_prefork already enabled Considering conflict php5 for php7.4: Enabling module php7.4. To activate the new configuration, you need to run: systemctl restart apache2 root@con1:~# systemctl restart apache2 root@con1:~# GEILomat das war die Lösung, oh jeh ich muss echt noch mehr lernen.... Danke für die tolle Hilfe Bleib gesund D A N K E S C H Ö N
    1 point
  7. Ich hatte mich nicht getraut, weil ich nicht den Server lahmlegen wollte unwissend, ob das überhaupt der richtige Ansatz wäre. Jetzt habe ich es gemacht, stellte sich heraus, daß Apache es nicht mochte, weil man die folgenden Apache-Module braucht: proxy proxy_http proxy_balancer lbmethod_byrequests Also: a2enmod proxy a2enmod proxy_http a2enmod proxy_balancer a2enmod lbmethod_byrequests Jetzt geht es! Ich bin begeistert, herzlichen Dank für die schnelle Hilfe und das großartige Programm!
    1 point
  8. Yes, it does. I have another server with froxlor running and I tested and it worked perfectly, so I am assuming theres some mismatch settings that maybe I manually made on Apache's config while learning/understanding/testing froxlor. So, thank you very much. I will post the solution when i find it so maybe it can help someone else. Bye
    1 point
  9. Super, hat funktioniert. Danke Dir vielmals für die super Unterstützung.
    1 point
  10. Vielen Vielen Dank. Ich werde von einem Server mit Debian zu Ubuntu wechseln und diese Schritte versuchen. Entschuldigung für mein Deutsch
    1 point
  11. Danke für die Rückmeldung. Also um erstmal einfach zu machen, kann ich doch den Hostnamen als Mailserver konfigurieren, sprich das Zertifikat davon einbinden. Und auch die Mailadressen von allen konnektierten Domains in externen Clients verwenden, muss dann eben als Servername für Ein-und Augangsserver den Haupt Hostnamen verwenden, ist das so einfach machbar. Danke
    1 point
  12. Habe es heute getestet und das Erstellen von Domains als Sub-Admin war erfolgreich. Vielen Dank für die Hilfe!
    1 point
  13. Nur zur Info: Ich hatte gerade das gleiche Problem mit "Permission denied: AH02454: FCGI: attempt to connect to Unix domain socket" nach einem Update auf 0.10.23.1 (absofort PHP 7.3 required). Als ersten Workaround half chmod 777 /var/lib/apache2/fastcgi/* Als ich dann nachgeschaut habe, sind die vermutlich fehlenden extra-Gruppen in /var/lib/extrausers/groups drin, denn jetzt funktioniert es auch ohne chmod 777 und den normalen Rechten srw-rw---- Ich kann mir auch nicht wirklich erklären, warum es plötzlich nicht funktionierte, wobei es mit der Umstellung der CLI default PHP Version zusammenhing. Zum Glück fand ich diesen Artikel, so dass ich nun doch den Abschluss 2020 feiern kann 🙂 Prost und guten Rutsch allen Froxlern und Danke an d00p für die vielen Fortschritte!
    1 point
  14. Ah, Danke! /root/.acme.sh hatte ich gar nicht auf dem Schirm. Ja, manuell gelöscht und zack, hat froxlor ein neues Zertifikat generiert, Problem solved! 👍 Das mit der falschen Adresse, ich nehme an zum Zeitpunkt des Generierens hatte ich wohl die alte Adresse noch in der Config übersehen bei den vielen hin und her *shrugs*
    1 point
  15. Das ist doch schonmal eine Aussage, die mich weiterbringt - ich muss außerhalb von Froxlor suchen. Danke.
    1 point
  16. I saw the Github notification. I didn't have the opportunity to test. Anyway, that fix worked.
    1 point
  17. For one of my friend's company this _could_ be interesting, if you have proper backups / depending on how those are handled. This is the biggest thing that keeps us from moving to other solutions, currently we use duplicity to backup encrypted on some cloud service(s) and moving elsewhere would mean usually a lot of drawbacks on the backups / backup retention time etc. But just see it as note, maybe many other customers have other problems / priorities and this won't be one with them maybe. Anyways: Good luck and success with your new project!
    1 point
  18. Hi zusammen, in Froxlor habe ich SSL aktiviert, ein Zertifikat zu einer Domain erstellt und der Domain den Port 443 zugewiesen. Jetzt startet der apache Server nicht mehr mit dem Fehler: apachectl[852]: (98)Address already in use: AH00072: make_sock: could not bind to address IP:443 Ich hab schon im Forum gesucht, einen Hinweis gefunden, dass ein "listing" Setting gesetzt sein könnte. Bewusst habe ich das nicht aktiviert. Ist jemand hier, der helfen kann? Kann natürlich gern mit Logfiles unterstützen Danke Euch und beste Grüße Tardar =============== edit: Kann gelöscht werden, konnte mir doch selbst helfen
    1 point
  19. Thanks @d00p it is working now 😀👍
    1 point
  20. Really appreciate your feedback. a2enmod ssl, yes. root@server6:/home/ubuntu# a2enmod ssl Considering dependency setenvif for ssl: Module setenvif already enabled Considering dependency mime for ssl: Module mime already enabled Considering dependency socache_shmcb for ssl: Module socache_shmcb already enabled Module ssl already enabled root@server6:/home/ubuntu# I am pretty certain it has something to do with the Oracle Cloud server setup. Something with the Virtual Nentwork adapter, the proxies in between etc. Not an expert on this and only a novice froxlor user so a bit over my head. Maybe one day somebody will pass by this forum entry and might have the solution for it. For now, it seems like not a good idea to use oracle cloud service for a LAMPF stack. I really like to thank you, d00p. Amazed at the level of support that you are offering via this forum. Hope the new adventure froxlor.com works our for you and your partners.
    1 point
  21. Sound great! Good luck + best wishes for your new project!
    1 point
  22. So I started over, patiently following all of the instructions. It's working brilliantly. Thank you so much for Froxlor. Great product.
    1 point
  23. Hallo, Postfix ist ein MTA und nicht über eine URL erreichbar. Gruss cardman
    1 point
  24. Hi @d00p, sry das ich mich so spät melde. Du bist ein Traum, hat natürlich direkt geklappt. Mit Ondemand dürften dann auch durch die idle time andere Fehler bei mir verschwinden. Vielen Dank für deine Antwort 🙂
    1 point
  25. Hi there, I finally could update to the latest Froxlor version with the testing repository. Thanks!
    1 point
  26. Das war DER Tipp! Jetzt funktioniert alles, wie gewollt. Vielen Dank!
    1 point
  27. Ja, danke! Das richtige Zertifikat wird nun auch verbunden von der richtigen Domain. Ich habe außerdem auf meinen Homepages noch die Lösung für einen Fehler gefunden: Es wurde angezeigt, dass "Ihr Verbindung ist nicht sicher und mit dieser Webseite geteilte Informationen können von anderen eingesehen werden" Das hängt damit zusammen, dass ein paar Grafiken noch per HTTP statt HTTPS eingebunden waren. Endlich alles geklärt und fertig 🙂 Juhuuuuuuuuuuuu
    1 point
  28. Thanks you very mucht for your work! I've already updates 4 hours ago witout any issue. BR Christian
    1 point
  29. Danke, hat so funktioniert! Falls jemand noch Warnungsmails bei Quotaüberschreitung benötigt, hier mein Setup: vi /etc/dovecot/conf.d/90-quota.conf plugin { quota_warning = storage=95%% quota-warning 95 %u } service quota-warning { executable = script /usr/local/bin/quota-warning.sh user = vmail unix_listener quota-warning { user = vmail } } plugin { quota = maildir:User quota } Das eigentliche Mail wird über dieses Script versandt (chmod 755): vi /usr/local/bin/quota-warning.sh #!/bin/sh PERCENT=$1 USER=$2 cat << EOF | /usr/lib/dovecot/dovecot-lda -d $USER -o "plugin/quota=maildir:User quota:noenforcing" From: support@XXXXX To: $USER Date: `date +"%a, %d %b %Y %H:%M:%S %z"` Subject: Ihr Postfach ist fast voll! Content-Type: text/html; charset=UTF-8 Content-Transfer-Encoding: 8bit Ihr Postfach $USER ist aktuell zu $PERCENT% belegt. Bitte archivieren oder entfernen Sie alte, nicht mehr benötige Nachrichten. Andernfalls könnte es vorkommen, dass Sie keine neuen Nachrichten mehr empfangen können! Bei Fragen stehen wir Ihnen unter XXXXX oder unter support@XXXX zur Verfuegung. Ihr Hosting Team EOF
    1 point
  30. I've struggled with this issue myself now for a couple of days. My goal was to activate Apache + mpm_event + php7.3-fpm. For now, i playing around with a WordPress installation and it runs fast as hell (considering WordPress with OPCache and RedisCache-Server, without any WordPress caching plugin). TTFB is around 170ms, I am satisfied. Finally I solved it ? (thankfully without fiddling in conf-Files) by disabling the Apache-conf for php7.3-fpm (in my case php7.3): a2disconf php7.3-fpm (removes /etc/apache2/conf-enabled/php7.3-fpm.conf) I searched for the string "php7.3-fpm.sock" in files like this: grep -iRl [text-string-to-search] [search-in-this-folder] grep -iRl 'php7.3-fpm.sock' /etc/ I found out this string is in /etc/apache2/conf-enabled/php7.3-fpm.conf. The file (or a symlink) php7.3-fpm.config MUST NOT be in the directory /etc/apache2/conf-enabled!! Other steps I made to get Apache + mpm_event + php7.3-fpm to work: a2dismod php7.3: the Apache php-module is not needed and anyway incompatible with mpm_event a2dismod php7.3 a2dismod mpm_prefork a2enmod mpm_event service apache2 restart Now check if mpm_event is running: apachectl -V The output should contain "Server MPM: event". Also check via phpinfo() if under "Server API" the value "FPM/FastCGI" is written. Other things I found out, it is not directly related to php-fpm, but I've struggled with issues at the same time: /var/customers/tmp/froxlor.panel/ has do be owned by froxlorlocal: chown froxlorlocal:froxlorlocal /var/customers/tmp/froxlor.panel /var/www/php-fpm/froxlor.panel/ has do be owned by froxlorlocal: chown froxlorlocal:froxlorlocal /var/www/php-fpm/froxlor.panel Check your Webserver-Settings: Settings -> Webserver-Settings: The username webserver and the groupname webserver has to be "www-data". Hope this helps someone. If I wrote anything wrong, please just leave a reply, i'm also grateful for other hints on this topic.
    1 point
  31. Einen neuen Kunden extra für phpmyadmin zu erstellen brauchst du schon mal nicht, aber was du erstellen musst, wenn du andere confs für php-fpm benutzen willst, ist halt ne eigene conf, das dauert keine 5min und ist im Panel ruck zuck gemacht. Und zwar unter PHP-Konfigurationen > Neue Konfiguration erstellen so mache ich dies auch bei vers. CMS die ich am laufen habe. Du musst dann nur nach dem erstellen der conf im Panel, einem oder dem einen Kunden die rechte für die php-conf geben. Kunden > Kunden bearbeiten > PHP-Konfiguration und fast ganz unten, dann die conf mit einem hacken aktivieren und schwups kannst du bei jeder domain wo der kunde besitzt die conf aktivieren.
    1 point
  32. An PHP wirds mit Sicherheit nicht liegen. Deine Aussagen sind allerdings zu dünn und konfus um jetzt konkret zu helfen. Erst schreibst Du POP3/IMAP tun und dann zeigst Du uns Fehler aus deren Log. SMTP geht nicht aber Du bleibst uns Logs schuldig. Soweit ich mich erinnere, sehen die Configtemplates von Froxlor keine eigene TLS/SSL Zertifikate für postfix?/dovecot vor. Was hindert Dich die Konfig von Debian 8 zu übernehmen? Im Zweifel mit Intelligenz und "diff". Ich habe vor einer Woche erst ein Upgrade von Debain 8 auf 9 mit installiertem Froxlor gemacht, da war nur bisschen im Dovecot anzupassen mit den Mailbox-Pfaden. So wie Du Dich hier ausdrückst, erweckt das den Eindruck, man könne Dir nur effektiv remote helfen. "d00p" hat dazu ein Bussines und andere wie ich könnten das vermutlich auch, wenn Du den per PM Logindaten rausgeben willst.
    1 point
  33. Ich hab auch die Mail bekommen. In meinem Fall war es aber so, dass ich bei mir zu Hause noch einen Rechner stehen habe, bei dem ich nicht froxlor nutze und stattdessen certbot per cron anwerfe. Hier war die Config falsch und es wurde noch als Authenticator "apache" benutzt - laut Doku kann dieser nur TLS-SNI-01. Ich habe dann auf "webroot" umgestellt und hoffe jetzt, dass alles weiter läuft Vielleicht prüfst du auch mal, ob du noch irgendwo certbot manuell nutzt - vielleicht noch von früher, als froxlor noch kein letsencrypt konnte oder so?
    1 point
  34. Subdomains für die du keinen seperaten Record eingerichtet hast, lösen nur auf die IP auf wenn ein entsprechender Wildcard Record existiert.
    1 point
  35. Doch bei Debian / Ubuntu gibt's das. Repository ist unter https://deb.sury.org zu finden. Anleitung: https://ansas-meyer.de/programmierung/php/rip-dotdeb-hello-deb-sury-org/amp/
    1 point
  36. Hi, Prinzipiell kannst du ohne Probleme einfach neue Zertifikate via lets encrypt anfordern, es gibt zwar rate limits, ich denke aber nicht, dass du entsprechend viele Domains hast. Hier genauer nachzulesen: https://letsencrypt.org/docs/rate-limits/ Die im/export Funktion übernimmt keine zertifikate, hier werden lediglich Einstellungen gespeichert.
    1 point
  37. 1 point
  38. Hmm.... irgendwie habe ich den Eindruck, dass Du hier völlig falsch bist.
    1 point
  39. Hallo, ich würde auch gerne noch meine Senf dazu geben Zum einen die Frage, wenn die Software in deinen Augen, soviele Defizite aufweist, warum benutzt du sie dann? Niemand zwingt dich Froxlor zu benutzen. Ich kenne einige Serveranbieter die bieten dir zu ihren Servern auch eine Plesk-Lizenz an. Da hast du dann ein "Rundum-Sorglos-Paket" und keine Probleme mehr. Ich von meiner Seite aus kann nur sagen, das Froxlor eine gute Software ist. Auf meinen Servern läuft die Software schon seit 10Jahren (anfangs noch unter SysCP). In meinen augen hält es eine gute die Waage zwischen Funktionialität und dem was ich als Server-Admin noch alles selber machen kann. Man wird nur in einem kleinen Rahmen zu irgendwelchen Software-Paketen gezwungen. Den Rest kann man mehr oder weniger selbst entscheiden was man installiert. Ausserdem kann man es relativ einfach selbst erweitern und an seine Bedürfnisse anpassen. Man muss sich da halt den Aufwand machen und selbst Programmieren, dafür hat man dann aber am ende eine Lösung die auf einen selbst massgeschneidert ist. Zu den "fehlenden" Funktionen: 99% meiner Kunden sind froh und zufrieden, das sie nicht so viel einstellen können, sondern das einfach alles so funktioniert, wie es funktioniert. Die wollen sich nicht mit dem Fach-Chinesisch eines Spamfilters auseinander setzen, die wollen einfach nur keinen Spam bekommen. In einer älteren Version von Froxlor gab es auch mal einen 1-Click-Installer. Dieser wurde insgesamt vielleicht 2mal benutzt, von daher ist das eine Funktion die ich nicht benötige. Für Backups gibt es, wie Shortie schon geschrieben hat, viele gute Programme, die das alle mehr oder weniger gut können. Also warum Manpower in etwas investieren was es schon gibt. Und zum guten Schluss, für die 1% Kunden, die weitere Funktionen Wünschen, biete ich an, diese über den Support anzufragen und dann von einem Admin ausführen zu lassen (sofern möglich). Gerade bei CronJobs weiß ich gerne was auf meinen Servern läuft und bin ganz froh, das nicht einfach jeder alles per CJ ausführen lassen kann. Zum Abschluss noch ein Dank an D00p und alle mitwirkenden für die Entwicklung und Pflege von Froxlor. Gruss Cardman
    1 point
  40. Reseller Accounts gehen über verschiedene Admin-Accounts Backups über die Benutzeroberfläche sind Augenwischerei und nur für temporäre Backups zu gebrauchen. Richtige Backup liegen auf externer Hardware und diese wird nicht einheitlich angesprochen. Mal ist es rsync, dann ftp und wieder andere machen NFS. Wie soll das eine verwaltungssoftware können? Auch Confixx konnte das nicht. 1&1 empfahl vor 10 Jahren Backups von Rootservern mit FTP auf deren Backupserver zu machen und auch das mußte händisch konfiguriert werden. Die meisten Benutzer sind mit den Einstellmöglichkeiten für Spamfilter usw. überfordert. Aus Erfahrung würde ich sagen das kennen und nutzen weniger als 5%. Wer soll die Pakete pflegen, aktuell halten und verwalten? Du als Nicht-Administrator? Willst du wirklich veraltete Pakete installieren? So sieht nämlich die Realität aus. Domainrobot hätte ich mir auch schon mal gewünscht. Aber bei genauerem Vergleich der Registrare wirst du feststellen, dass jeder seine eigene API bzw. Schnittstelle hat und somit unmöglich ist das generell einzuführen. Host Europe arbeitet m.W. sogar heute noch nur mit einer E-Mail Schnittstelle, was im Umkehrschluss bedeutet dass auch die Antworten nur per E-Mail kommen und diese dann aufwendig geparst werden müssen.
    1 point
  41. Dein Problem: Du hast etwas installiert was nicht Bestandteil von Froxlor ist ohne es selbst händeln zu können :-) was sagen die Logdateien aus? werden die Zertifikate an die richtige Stelle installiert? hast du den Mailserver neu gestartet? hast du überprüft ob der Mailserver das richtige Zertifikat benutzt?
    1 point
  42. Steht doch in der Meldung, er kann nicht auf die DBs zugreifen, weil die PW's nicht stimmen oder nicht gesetzt wurden während dem install.
    1 point
  43. Hi, @ninopi d00p war doch ganz korrekt. Nur glaube ich hast du leider nicht ganz verstanden wie es funktioniert und daher hat er mehrmals versucht zu helfen aber du hast darauf nicht richtig reagiert. Versuche doch einfach mal bitte im Verzeichnis /var/www/froxlor/.well-known/acme-challenge/ eine test.html Datei anzulegen und diese dann über deine Subdomain http://SUBDOMAIN/.well-known/acme-challenge/test.html aufzurufen. Weißt du was ein Apache Alias ist? Den hast da da oben geposted. Der sagt, dass wenn man http://SUBDOMAIN/.well-known/acme-challenge/ aufruft im Verzeichnis /var/www/froxlor/.well-known/acme-challenge/ landet. Daher musst/sollst/darfst du .well-known NICHT im DocumentRoot deiner Subdomain anlegen. Das gehört da nicht hin und wird auch durch den Alias übersteuert. Bei weiteren Verständnis-Problemen lies dir einfach mal die Apache Dokumentation bzgl. Aliases durch. Das kann durchaus Licht ins Dunkel bringen. Grüße Chris
    1 point
  44. Zeigt die SubDomain denn auf deinen Server? Ist die denn ohne SSL auch richtig erreichbar? Du kannst den Cronjob auch mal manuell aufrufen: /usr/bin/php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug durch den Debug Parameter kriegt man da ne menge mit.
    1 point
  45. Poor, retarded and isolated kid... I wish you all the best for your mental health dude...
    1 point
  46. ja weil Froxlor und dein Server keine automatische Konfiguration unterstützt. Du mußt das manuell konfigurieren.
    1 point
  47. 1 point
×
×
  • Create New...